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ACT! Calendar to Excel

Purpose of the add-on

ACT! Calendar to Excel is an add-on that allows you to export your calendar to Excel, i.e. create an
activity report sorted by date with the ability to include any contact, company or activity field as well
as with the great formatting possibilities that Excel offers.

Installation procedure

Download the program file from our download page and double-click it to start the installation.

Note: add-ons are now DLL files and not executable files. This means that they are automatically
initialized by ACT! when placed in ACT! plugin folder (a subfolder of the main ACT! directory) and
cannot be started from the Windows Start menu anymore. This is why you are not given a choice of
installation directory during the installation process.

How it works

To start the add-on, look for the icon on your Contact toolbar.
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The interface should be pretty much self explanatory. Under the General tab, you select the date
range you want to print a calendar for, the calendar template you want to use.

= ACT! Calendar To Excel 5
File Options Help

| General Fiter || Options |

0K
Diates to export -
) Today ) Tomomow
() This week () Next wesk
() This month {#) Next month
() Specfiic dates:

Excel Calendar Template to use:

Standard XLT szl

You can click the ... Button next to the template box to select any template.
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Under the Filter tab, you select the filtering options.

== ACT! Calendar To Fxcel =
File Options Help

|GE!I'IE!IE|| Fitter iOptionsi

QK
Filter Options: _
Users: Types: Priorities
[ Allison Mikola [ﬁ] vl Call vl High
[ Betty Browser vl Meeting vl Medium
[w| Chris Huffman vl To-do [l Low
[_] Ernst Anderson I Marketing Call
["] Fred Fenderlin Il Personal Activity
[] Juliette Rosseu | |l Test
[] Melissa Pearce |1| vl Wacation
[ Al [ Mome ] [ Al [ Mome ] [__AI | [ MNome |
[15how cleared activities [ Show timeless

Under the Options tab, you select the Output options:

" ACT! Calendar To Excel &
File Options Help

IGenemI-;i Fitter | Options |

0K
Output options: -
Cancel
Hide days without activities
Hide week-ends

[ Use ACT! activity colors
Automatically expand row height to fit content

NOTE: Checking Automatically expand row height to fit content is recommended as Excel will
automatically reset the height of all rows so that the content of all cells be visible.
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Then you press OK and the calendar displays itself in Excel

- =
B & D

CALENDAR

For: Chris 06/01/2006 - 06/30/2006
Huffman

Thursday, June 01

Day 151 Week 22

12:00 AM Chris Huffman acation
2 days 18 hours CH Gourmet Gifts

Saving your calendar settings

Your last calendar settings are automatically saved so that, the next time you open ACT! Calendar to
Excel, they are automatically loaded.

You may also save them permanently. To do this, go to the File menu and choose Save Current
Settings...

" ACT! Calendar To Excel
File Options Help

Mew Template
Edit Template. ..

Load Calendar Settings...
Sawve Current ﬁtﬁngs. -

Exit

You will be then prompted to enter a name for the settings file.

Once this is done, you can load your settings at any time by doing File > Load Calendar Settings...

The next section called Templates is of interest to you if you want to create your own templates,
modify existing templates. If you are fine with the templates supplied with the add-on, you do not need
to read it.
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Templates

Creating or editing a template

ACT! Calendar to Excel uses a template file to create your calendar in Excel. This template file has a
XLT extension

NOTE: It is not a regular .XLT file: it contains macros necessary to the addon to correctly merge the
information. So you could not just take any existing .XLT file on your system.

You can create a new template by going to File > New Template or you may want to edit the existing
templates using the File > Edit Template... command.

In both cases, Excel opens and your get a special window allowing you to insert fields and define
sections.

ACT! Calendar To Excel &
Fields:
— Close
el e
B Regarding i

e

& Activity field )
Duration

" Contact field Date
Start Time:

-~ End Time

Company field Resources

Priority

(™ Calendar field Location
Scheduled With =

Insert

Sections:

Create a section from the selected range

If you close this window, and need to open it again, go to Excel Insert menu and look for ACT!
Calendar Fields...

Insert | Format Tools Data

Cells...
Rows
Columns
Worksheet

[ﬂ Chart...

Symbal...

Page Break

#  FEunction...

MName 3
i'd Comment

Picture ]
¢%  Diagram...

Object...
% Hyperlink... Ctrl+

ACT! Calendar Fields. ..

L
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Understanding the different sections

To render properly a calendar, a template needs to contain several sections. None of these sections are
mandatory but if the template has no section, the calendar will be blank.

Main sections

The main sections are;

the Header section is inserted once at the top of the calendar.

the Day section is inserted for each day to be displayed before any activity in the day
the Activity section is inserted for each activity

the No activity section: this section is inserted when a day has no activity

the footer section is inserted once at the bottom of the calendar

Here is an example.

CALENDAR

For Chris 06/01/2006 - 06/30/2006
R Header Section

Thursday, June 01

12:00 AM Chris Huffman vacation
2days 18 hours  CH Gourmet Gifts
Activity Section

Sections are just areas of the templates that are named with the section name. If you wish to select a
section or see which sections are available, click the Name box of your Excel template. This is the
dropdown to the left of the insertion box. If you click one of the section names, the section becomes
selected in the document.

Microsoft Excel - Standard.XLT
@ File Edit Wew Insert Format Tg
DEeEH &AY & B@E
i3 T ¥
1 -5
Activity » B
Call L[
Day E
Footer L For: [[G:Filtered
Header
Meeting
MNoActivity
[ &

& |
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More specific sections

Day sections

Typically you want the same Day section to be inserted at the top of the activities for a day.
But you may want to have different sections depending on the day of the week to make them
stand out for example. You can create Monday, Tuesday, Wednesday, Thursday, Friday,
Saturday and Sunday sections.

The logic is that before it inserts a new day, the add-on first looks for the corresponding day-
specific section and if it can’t find one, it uses the generic Day section.

NOTE: The same area of the Excel document may be named several times. If you want your

Monday and Thursday section to be identical, you can select the same area and name it twice.

Here is an example. We have created a Monday section with different colors to have all
Mondays stand out as they mark the beginning of the week.

CALENDAR

For: Chriz QEAONZ00E - 063042008
Huffman

Thursday, June 01

12:00 AM Chris Huffman Wacation
2 days 18 hours S Gt (s

Monday, June 05

DOay 155 wack 23

5:16 PM fl Benny Lender Confirm Shipment
10 minutes Bt Lenter Fnancing
(A R

Tuesday, June 06

Activity Sections

You can have Call, Meeting, To-Do sections as well as sections for any type of custom
activities. This way each type of activity may be displayed according to a different layout.

In the example shown above under Days sections, you can see that activities displayed have
different icons and different field layouts. That’s because one activity is a Call and the
template has a Call section and another is a Personal activity and the template has a Personal
activity section.

The logic is that before it inserts a new activity, the add-on first looks for the corresponding
activity specific section and if it can’t find one, it uses the generic Activity section.
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Here is what it looks like in the template we used for the example above. You can see a Call
section, then the Meeting section, The To-do section and the Personal Activity section.
Each section has a different layout.

[[A:Start Time]] [[A: Scheduled With]] [[A-Regarding]]
[[A:Duration]] [TCY-Compamy]]

[C:Phone]] [[C Extension]]
[[A:Start Time]] ¥4 [[A:Scheduled With]] [[A-Regarding]]
[[A:Duration]]

[[A:Start Time]] ?ﬂ‘ [[A: Scheduled With]] [[A-Regarding]]
[[A:Duration]] CY Company]]
[[C:FPhone]] [[CExensian]]

As a summary, let’s remember that you do not have to create all these sections. At least you need an
Activity section so that your calendar can display something. Typically you would want to have a
Header, Day and Activity section. But if you want to have more control, you just create specific day
or activity sections.

The best way to learn and understand how these sections work is to look at an existing template in
edit mode.
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Adding/modifying a section

To create (or modify) the Header section for instance, select the cells you want contained in the

Header section, then click the Create a section from the Selected Range button.

B

&

D

For: [[G:Filtered

CALENDAR

[[G:Calendar Start Date]] - [[G:Calendar End Date]]

#VALUE!

[[A:Start Time]]
[[A:Duration]]

[[A:Scheduled V]
CY-Companyll

ACT! Calendar To Excel

Mo activity

[[A:Start Time]]
[[A:Duration]]

[[A:Scheduled V|
[ICY-Companyll
[iC:Phone] [fC:H

Fields:

Field type

(* Activity field
" Contact field
" Company field

™ Calendar field

Close

Regarding -
Type

Details

Duration

Date

Start Time

End Time

Resources

Priority

Location

Scheduled wWith |

Insert

Sections:

Create a section fiom the selected range

My

[[A:Start Time]] F# [[A:Scheduled Vi

AR m TR TN

[T e g o 7T

Then choose Header in the list of sections and press OK.

Insert a section

Select the section you want to create:

Header ia
Footer —
Activity
MoActivity
Day
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday
Call
Meeting

To-do ﬂ

Cancel

[
o |
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How to delete a section

Go to the Excel Insert menu, and then choose Name > Define. In the Define Name window, select the
section you want to delete and click Delete.

Define Mame
Mames in workbook:
| [ ok |
Activity -
Call Close
Day

Footer Add
Header —
Meeting

MoActivity Delete

Personal_Activity

Print_Area Calendar
Saturday j
Refers to:
[=Calendar!sF$21:55523 |

Inserting fields in sections

To insert fields in the template, first select the cell you want to insert a field in. Then in the ACT!
Calendar To Excel window, select the type of field then the field you want to insert. If the cell already
contains a value or a field, you will be prompted to choose between overwriting and appending to the
current content of the cell.

vl
ACT! Calendar To Excel
Fields: 1
Field ty Close
ield type |
Regarding =
T
& Actvity field ko)
Duration
" Contact field Date
Start Time
— End Time
B Resources
Priority
(™ calendar field Location
Scheduled With i

Insert

Sections:

Create a section from the selected range J

You may insert activity fields, contact fields, company fields (provided the contact field belongs to a
company) or calendar fields.
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Calendar fields are related to your calendar settings (like the start and end dates). Typically you
would insert them in a header or footer section.

ACT! Calendar To Excel

— Fields:

cl
Field type - ﬁ

Current User
Calendar Start Date
Calendar End Date
Database Name

" Contact field Display Options
Filtered Priorities
Filtered Types
Filtered Users
Summary

" Activity field

(™ Company field

Insert

[ Sections:

Create @ section from the selectad range

Remember that for a field to be replaced by a value, you need to have it inserted in a section.

Formatting sections

Sections can be formatted any way you want.

There is just one thing to remember and it concerns font colors if you use the Use ACT! activity
colors under the Options tab (see below).

== ACT! Calendar To Excel
File Options Help

| General | Fiter | Options L

Output options:
Include days without activities
[Jinclude wesk-ends
[ Use ACT! activity colors
Automatically expand row height

to fit contert

In that case, the add-on will automatically use the activity color as set in ACT! to display the activity
information in all cells which font color is set to black.
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Let’s take an example. Below is the Call section of a template.

[[A:Start Time]] [[A: Scheduled With]] [[A:Regarding]]
[[A:Duration]] ICY-Company]]

[fC:Phone]] [[C:Extension]]

If you do not check the Use ACT! activity colors option, the result will look like this:

Monday, June 05

Day 155
516 PM Benny Lender Confirm Shipment
10 minutes Best [ ender Financing

(847) 555-2221

If you do check the option and the activity is displayed in blue in ACT!, the result will look like this:

Monday, June 05
Day 155
516 PM % Benny Lender Confirm Shipment
10 minutes Best Lender Financing

(847) 555-2221

Only the cells that were in black in the Call section have been converted to blue. The other cells kept
their original color.
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Registering your product

To continue using this product past the trial period, please buy a license at www.exponenciel.com.
Licenses are issued for one ACT! username and will only work for that username.

Once you get a license code, either click the Register now button of the nag screen or go to the Help
> About menu and once the About window opens, type the registration code in the appropriate box
and click OK. You might need to close and restart ACT! to complete the registration process.

Support

For support, contact support@exponenciel.com.

Rev. April 7,2009 —v. 6.0.0
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